[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't check in with CVS 1.11.21

From: Jim Hyslop
Subject: Re: Can't check in with CVS 1.11.21
Date: Wed, 23 Nov 2005 13:02:56 -0500
User-agent: Mozilla Thunderbird 1.0.6 (Windows/20050716)

Hash: SHA1

Simon Renshaw wrote:
> I always get a "connection refused" message when I try to access CVS
> with pserver even if port 2401 is open. I have to use extssh to connect
> to CVS.
Is that going to cause major problems? If not, go with the extssh rather
than pserver.

Have you tried the troubleshooting steps in the manual:

> I can do a check out just fine. I then created a new file and tried to
> check it in and got the following error message: "cvs [commit aborted]:
> 'user' is not allowed to commit files".

Does it say 'user' or does it say 'root'? I grepped the source code for
"not allowed to commit", and the only error message I found was:

commit.c:   error (1, 0, "'root' is not allowed to commit files");

Make sure you aren't trying to run CVS as root. CVS refuses to run as
root, for security reasons.

- --
Jim Hyslop
Dreampossible: Better software. Simply.
                 Consulting * Mentoring * Training in
    C/C++ * OOD * SW Development & Practices * Version Management
Version: GnuPG v1.4.2 (MingW32)
Comment: Using GnuPG with Thunderbird -


reply via email to

[Prev in Thread] Current Thread [Next in Thread]