[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: cvs pserver with too much "--allow-root=..." arguments?!

From: Todd Denniston
Subject: Re: cvs pserver with too much "--allow-root=..." arguments?!
Date: Fri, 13 Jan 2006 09:54:15 -0500
User-agent: Mozilla Thunderbird 1.0.7-1.1.fc4 (X11/20050929)

address@hidden wrote:

I run 17 cvs repositories by using 17 "--allow-root=CVSROOT" arguments
in my inetd.conf. Problem: When trying to use more repositories (e.g.
21), the additional repositories aren't accessible via pserver.

Any ideas?

Thanks in advance,
Sebastian Schwerdhoefer

You have run into the dreaded [x]inet command line length limitation.

It can be solved by using a shell script to pass your options instead of 
see the following for help:

I think that the info contained in Larry's email should probably be included in either the Multiple repositories section[1] or the "Trouble making a connection to a CVS server" section[2], but I do not have time now to make a patch.

A similar but probably less secure script was submitted once by Gary Young:

>> On Thu, Apr 27, 2000 at 11:34:49AM -0700, Gary Young wrote:
>>> > I point inetd.conf at a script:
>>> >
>>> > #!/bin/sh
>>> > /usr/bin/cvs \
>>> >   `ls -d /cm/vault/* \
>>> >    | sed '1,$s/.*/--allow-root=&/'` \
>>> >   pserver
>>> >
>>> > I have my repositories in /cm/vault.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]