[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

cannot mkdir /tmp/cvs-servpid

From: address@hidden
Subject: cannot mkdir /tmp/cvs-servpid
Date: 24 Feb 2006 09:24:00 -0800
User-agent: G2/0.2

Hello all,

I have been using for a while now (at least for the past year) cvs
through ssh. My install is the following:

A WinXP home pc running cygwin and the following 'cygwin apps' : ssh
and cvs. I have a cvs repository sitting on that PC.

I am connecting from a work pc (running WinXP as well) via ssh to the
home pc with passauthentication set to no and this ssh connection works
fine. I have configured cvs (for that I have set the CVS_RSH and the
proper CVSROOT) on the work pc so as to access the repository sitting
on the home PC. For the past year, everything went fine and worked

Recently I had to re-install WinXP on my home pc. I have re-installed
cygwin on this home pc, did all the necessary configuration at ssh and
cvs layers but I can no longer do any cvs operation (checkout, update,
etc. do not work) but ssh still works fine as before. I have
cross-checked every possible configuration and version details on both
PCs. Even from the home pc, I have tried to connect via ssh to the
repository (CVS_RSH=/bin/ssh and
CVSROOT=:ext:address@hidden:/cygdrive/c/arcroot ) but I am getting the
same error.

The error message is
cannot mkdir /tmp/cvs-serv2916/.
No such file or directory

I have run cvs commands with the global -t option and nothing
particular seems to be displayed.
 -> main loop with
 -> safe_location( where=(null) )
 -> Starting server: /bin/ssh -l teggy localhost cvs server
S-> my_module (backup, Updating, , )
cannot mkdir /tmp/cvs-serv2916/.
No such file or directory
 -> Lock_Cleanup()
 -> Lock_Cleanup()

What puzzles me is that cvs is trying to mkdir /tmp/cvs-serv2916/. and
indeed this command with the trailing /. cannot work ("mkdir
/tmp/cvs-serv2916" works but "mkdir /tmp/cvs-serv2916/." does not work)

Has anyone come across this problem ?

The latest cvs version downloaded via cygwin setup is 1.11.21 ...

Please helppp !!!!!! I'm now short of hints to try :)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]