[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: can't seem to checkout from my pc running cygwin on XP

From: René Berber
Subject: Re: can't seem to checkout from my pc running cygwin on XP
Date: 19 Jun 2006 16:48:05 -0700
User-agent: G2/0.2

Please wrote:

> Running cygwin in rxvt with cvs 1.11.17 on XP -- all up to date.
> Can someone suggest a possible cause/fix for this?
> $ cvs co build
> U build/make_includes/
> Disconnecting: Timeout, server not responding.
> cvs [checkout aborted]: end of file from server (consult above messages if 
> any)
> This sort of thing has happened on every checkout I've tried from our local
> repository.  I tried several different top level directories and same thing.
> I've checked out large projects from public repositories with no problems.

Might be problems with CR-LF translation, either you have your
repository on a text-mode mount point or you are using csh; both of
those will get you CR-LF translation when cvs is not expecting any, and
this is Cygwin specific.

Something similar could be caused by not declaring binaries in the
repository's cvswrappers.  Again something is translating CR-LF to LF
and cvs is waiting for a number of bytes to arrive but translation has
cut the file short.

Solution: use only binary mounts, try another shell (bash works fine),
define binary types of files in cvswrappers.

René Berber

reply via email to

[Prev in Thread] Current Thread [Next in Thread]