[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

does cvs history with -n module work?

From: John Lemire
Subject: does cvs history with -n module work?
Date: Thu, 22 Jun 2006 10:29:40 -0700



I’m a cvs novice and having difficulty with the history command when used with the –n module param.


If I run this command:


cvs history -c -al -n mymodule -D2006-06-15


I get “No records selected.”


However if I remove the –n mymodule I get the list for all the modules and I can see entries for mymodule in it.


I am using a version of the client that supports –n (at least it’s in the help)

I don’t know if this means the server does too or not.

I get the same results from both windows and unix cvs clients.


Can any shed some light on this? Maybe the syntax is just wrong…


Also what I’m really trying to do here is see if my local source is up to date without writing to any files in the module directory on the local disk.

The history command seems like a particularly inefficient (read slow) way to do this.

Something more like cvs -q update –dP would work better if it worked like it does with the –n when nothing is out of date (ie didn’t create the .backup file, etc)


I am restricted from adding new notification commands on the cvs server side and am trying to circumvent this by having one daemon that watches for changes to the local source directory which can trigger local notification commands and another daemon that “polls” the cvs server using cvs commands that update the local source.  Unfortuantely cvs update creates/changes lots of files in the local source dirs even when no files are out of date which errantly triggers the directory monitoring deamon.


Anyone know of a better strategy to accomplish this?



Thanks J



reply via email to

[Prev in Thread] Current Thread [Next in Thread]