[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: "cvs ls" and "cvs rls" cause Segmentation fault

From: Mark D. Baushke
Subject: Re: "cvs ls" and "cvs rls" cause Segmentation fault
Date: Thu, 14 Sep 2006 22:07:22 -0700

Hash: SHA1

Mark Novak <address@hidden> writes:

> Whenever I execute a cvs ls or cvs rls command I get a Segmentation
> fault, like this:
> address@hidden:~/pvm3/sockets> cvs ls
> ClientSocket.cpp
> ClientSocket.h
> Makefile
> Makefile.aimk
> ServerSocket.cpp
> ServerSocket.h
> Socket.cpp
> Socket.h
> SocketException.h
> messages.h
> simple_client_main.cpp
> simple_server_main.cpp
> Segmentation fault
> address@hidden:~/pvm3/sockets> cvs rls
> cvs rls: Listing module: `.'
> sockets
> Segmentation fault
> It appears that all the files are listed before the Segmentation
> fault.  This only seems to happen after I've committed changes beyond
> the initial import.  I've rebuilt the CVS database twice and the
> problem appears the same both times. I'm running CVS 1.12.12 on Suse
> 10.1. If anybody has a clue as to what's causing this I'd be glad to
> hear it.

Are you in client/server mode? What method of transport :ext: or
something else? Have you tried 'cvs -ttt ls' to have cvs tell you what
it is doing?

You have provided very little useful information ... the Novell folks
have patches of their own against cvs 1.12.12. Do you have
cvs-1.12.12-19 or some other release? What hardware is your host?
i386? x64_86? ppc?

Have you tried to debug the problem? Do something like 'ulimit -c unlimited'
and when you have the core dump do a 'gdb /usr/bin/cvs core' and at the
(gdb) prompt do a 'bt' command to figure out where the crash is happening?

        -- Mark
Version: GnuPG v1.4.4 (FreeBSD)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]