[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

branches (a desperate story...)

From: address@hidden
Subject: branches (a desperate story...)
Date: Mon, 30 Oct 2006 16:31:25 +0100
User-agent: Thunderbird (Windows/20060909)


i have been using cvs without using branches for more than 2-3 years for a small project developed only by myself. a couple of days ago i decided to use branches and by now i feel completely lost.

what i decided is to have one stable branch, so that i can do more bold experiments in the trunk. until now i have always done very small improvements only and the trunk has been almost stable all the time.

so i did -

cvs rtag -b branch_name

then -

cvs -q update -A

and then i submitted all unstable changes into the trunk -

cvs commit -m "All unstable changes into the trunk."

then i started to move between the trunk and the branch using -

cvs -q update -r branch_name


cvs -q update -A

So far all worked fine. I could commit trunk and branch changes.

The problems started when I decided to try to see the changes in the trunk from the branch -

cvs -q update -r branch_name
cvs -n update -j HEAD

What I get all the time is a report on only one file (I have more than 20-30 changed) which tells -

cvs update: Updating .
RDS file: /path/to/this_first_file
retrieving revision 1.4
retrieving revision 1.6
Merging difference between 1.4 and 1.6 into this_first_file
cvs update: this_first_file: No such file or directory.

If I run instead (on a copy of my checked out version) -

cvs update -j HEAD

(without -n) - all gets merged nicely.

I found a bug reported in 2003 (unfortunately i did not save the link, it was in something like savannah) reporting exactly this broken behaviour, and still not fixed. But I do not know if this is the case.

I spent the last 24 hours reading documentation, searching and I can't go around this. I wrote to the list and somebody suggested that I use -

cvs -n update -j 1

but I end up with the same result.

I set up a mini cvs repository on my machine and created a file and tried the above described operations (branch, etc.) - and I do not get this error.

I wonder if it is possible that I have messed up something during the branching process and how can I get out of that.

A lot of help will be appreciated as my brain is completely burned out by now and I have no clue how to go on.

Thanks everybody,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]