[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Puzzle with "cvs -n update -jLABEL"

From: address@hidden
Subject: Puzzle with "cvs -n update -jLABEL"
Date: 8 Nov 2006 11:20:40 -0800
User-agent: G2/1.0


    I have a CVS repository containing a file named "ChangeSets" at its
    root level.  This file is automatically generated, but it's a plain
    text file.

    I have a branch; call it BR_locks, because that's its name.  I've
    committed some files on that branch, and now I want to merge it to
    HEAD.  I go to a sandbox on HEAD and issue the command

        cvs -n update -j BR_locks

    to see what files will be merged in.  I see the following:

        cvs update: Updating .
        RCS file: /scratch/cvsroot/ExtendCVS/ChangeSets,v
        retrieving revision 1.2
        retrieving revision
        Merging differences between 1.2 and into ChangeSets
        cvs update: ChangeSets: No such file or directory

    and the program immediately exits with status "1", ignoring the
    rest of the sandbox (which does contain other files that will be

    This seems to me to be broken behavior; I've used command lines
    like this many times in the past, and have never seen this happen.

    What's particularly peculiar is that if I remove the "-n" option
    then the merge goes through to completion with no problems

    Don't know if it matters, but I'm using cvs version 1.11.17.

What I've tried:

(1) "cvs rlog" doesn't show anything unusual about ChangeSets.
(2) There's no 'invisible' whitespace in the filename of ChangeSets in
    the sandbox or ChangeSets,v in the repository.
(3) The behavior has nothing to do with the name of the sandbox, even
    if it's not the same as the repository.
(4) I've tried using "-I ChangeSets" in the command line, and cvs seems
    to ignore it.
(5) I've tried setting my CVSIGNORE envar to have ChangeSets in it.
    Also ignored.
(6) I've tried creating a .cvsignore file in the sandbox.  Also
(7) I normally run with pserver access.  Changing to local access
    doesn't change anything.
(8) I've tried renaming ChangeSets to "csets" in my sandbox and in the
    appropriate CVS/Entries file, and renaming ChangeSets,v in the
    repository to "csets,v".  No difference.

I'm fresh out of ideas.  Can anyone help?

(Please respond by Email as well as on the board.)

Howard Siegel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]