[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: branches (a desperate story...)

From: address@hidden
Subject: Re: branches (a desperate story...)
Date: 9 Nov 2006 04:47:46 -0800
User-agent: G2/1.0

address@hidden wrote:
> hello,
> i have been using cvs without using branches for more than 2-3 years for
> a small project developed only by myself. a couple of days ago i decided
> to use branches and by now i feel completely lost.
> what i decided is to have one stable branch, so that i can do more bold
> experiments in the trunk. until now i have always done very small
> improvements only and the trunk has been almost stable all the time.
> so i did -
> cvs rtag -b branch_name
> then -
> cvs -q update -A
> and then i submitted all unstable changes into the trunk -
> cvs commit -m "All unstable changes into the trunk."
> then i started to move between the trunk and the branch using -
> cvs -q update -r branch_name
> and
> cvs -q update -A
> So far all worked fine. I could commit trunk and branch changes.
> The problems started when I decided to try to see the changes in the
> trunk from the branch -
> cvs -q update -r branch_name
> cvs -n update -j HEAD
> What I get all the time is a report on only one file (I have more than
> 20-30 changed) which tells -
> cvs update: Updating .
> RDS file: /path/to/this_first_file
> retrieving revision 1.4
> retrieving revision 1.6
> Merging difference between 1.4 and 1.6 into this_first_file
> cvs update: this_first_file: No such file or directory.

Curious!  I just reported the same problem yesterday!  (No, I don't
know how to fix it either.)

> If I run instead (on a copy of my checked out version) -
> cvs update -j HEAD
> (without -n) - all gets merged nicely.
> I found a bug reported in 2003 (unfortunately i did not save the link,
> it was in something like savannah) reporting exactly this broken
> behaviour, and still not fixed. But I do not know if this is the case.
> I spent the last 24 hours reading documentation, searching and I can't
> go around this. I wrote to the list and somebody suggested that I use -
> cvs -n update -j 1
> but I end up with the same result.
> I set up a mini cvs repository on my machine and created a file and
> tried the above described operations (branch, etc.) - and I do not get
> this error.

As it happens, I'm working with a very small and very new repository.
I'll try the "cvs -n update -j 1" dodge myself, but I suspect it won't
any better for me than for you.

And at least now I know that I can eliminate as a possibility something
I had been considering.  (No, it's not relevant for anyone else.)

> I wonder if it is possible that I have messed up something during the
> branching process and how can I get out of that.

It's possible, of course, but I don't think so.  My own apparently
identical problem arose in a circumstance where I wasn't shifting
back and forth between branches in the same sandbox.

I will suggest, however, that rather than doing such shifting you
simply create _two_ sandboxes, one on the trunk ("HEAD") and one
on your branch.  That way it will be much less likely that you'd make
changes on the wrong branch.  (You can either do your initial
"cvs get [-r branch] repos" in differently-named directories or you can
do "cvs get -d HEAD repos" and "cvs get -d branch -r branch repos".

> A lot of help will be appreciated as my brain is completely burned out
> by now and I have no clue how to go on.
> Thanks everybody,
> Iv

Good luck.  And if you discover anything, PLEASE let me know!


Howard Siegel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]