[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: init error in Suse 10.1: cannot get working directory: File exists

From: Frank Jelinek
Subject: Re: init error in Suse 10.1: cannot get working directory: File exists
Date: Wed, 25 Jul 2007 22:17:49 +0200
User-agent: Thunderbird (X11/20070615)

Hi Todd,

thank you for answering. Actually I made some additional tests. At first I tried your hints, but no changes. My root-home ist root-Writeable, so there is no problem.

I patched the source code to tackle the problem. Result: the xgetcwd func seems to fail. I replaced it by the native getcwd and everything works.

This could be an issue for the development mailing list, therefore I cc'ed to this list. Perhaps one of the developer could take a look at the problem, I guess that there is a platform incompatibility with the gnulib


Denniston, Todd A CIV NAVSURFWARCENDIV Crane, Code 6067 wrote:
address@hidden wrote:

I'm looking for help. Actually it is not my first cvs system I set up, but the problem is new to me.

I have a Suse 10.1 root server. There I install cvs, I tried the standard yast installation (seems to install a suse-patched cvs 1.12.12) and I tried a self-compiled 1.12.13. Both results in the same problem.

I'm logged in as root (with other users it is the same) and I try to create a new repository with the command

cvs -d /root/cvs init

The result is

cvs [init aborted]: cannot get working directory: File exists

The same result I get if I try any other command and with different user accounts. I also tried the

cvs -t -f -d /root/cvs init

options. Then I get

  -> main: Session ID is L7NaPCpnLvgrC7rs
cvs [init aborted]: cannot get working directory: File exists

with google etc I did not found any hint, so I hope that someone here could help me. Is there anyone who have a similiar problem? And a solution ? Or ca I tackle the problem trough changes in the source code?


How about trying
mkdir /tmp/opencvstest
cvs -t -f -d /tmp/opencvstest init

If you still get a fault, I would guess it has something to do with the new 1.12.X signing options, look in the options to turn it off[1].

If it works, my guess at the reasons for fault are
A) cvs does not work when you are root (Design/security decision of the CVS authors). B) most Linux installs set /root/ as only readable and executable by root:root so no other user can read or write there. Thats why you often see folks putting CVSROOT in /var, /usr, or better yet /cmpartiton.

[1] as mark is talking about, you probably don't have the signing problem, but just in case I mention it:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]