[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Help regarding CVS

From: Todd Denniston
Subject: Re: Help regarding CVS
Date: Wed, 05 Mar 2008 19:03:14 -0500
User-agent: Thunderbird (X11/20071031)

please download
to your home directory and put a copy of it in /tmp.

cd /tmp
tar -xjvf cederqvist-1.11.22.html.tar.bz2

Sadia Tahseen wrote, On 03/05/2008 06:18 PM:
Ihave a doubt ,please check below.I also wanted to tell you that I havedone as you told me to on the server machine logging in as "root".

OK, mistake.
look at
search down in the file to the second instance of:
"is not allowed to commit files"
Summary: Do not use root as one of your users.
Security Summary: Do NOT use root unless you HAVE TO!

Butwhen I logged out and logged off as root and again logged back in asroot on the server machine (by ssh through the root of clientmachine),
I  was again asked CVSROOT setup.

This is because the environment does not remember changes you only make IN the environment.
That is why I told you to
export CVSROOT=/appl/src/cvs/JavaAppl
each time you were to change users below.
Hint for later: understand .bashrc

It shows
No CVSROOT specified!please use -d option
Why is it so.
I have already tried committing it ,
but it says there are some errors when I type the following

1.cvs add projectdir/mydate
2.cvs commit -m"a comment" projectdir/mydate

cvs add: in directory .:
cvs [add aborted]: there is no version here; do 'cvs checkout' first

I HAVE TRIED  using checkout too  so it update projectdir but still shows the 
above errors.

First I was not expecting you to be running as root, this breaks ALL kinds of expectations not just for cvs. if you add a user (`man useradd`) and then login as that user THEN execute the commands to create the repository and check it out, things should work. You really should not accept at face value commands folks on the interweb give you to run as root, but here is a suggestion:
`useradd --create-home tahseen`
`passwd tahseen`
#for details see:
man 8 useradd
man 1 passwd

add tahseen to the sadiascvsgroup, i.e., modify /etc/group to
Then login as tahseen and try the cvs stuff again, remembering you will need to export CVSROOT in each terminal until you understand .bashrc and how to convince your terminal to come up as a login terminal.

for the 2 command the errors it shows:

cvs commit -m "a comment" projectdir/mydate
cvs commit: use `cvs add' to create an entry for projectdir/mydate
cvs [commit aborted]: correct above errors first!

Please let me know what should be done

Thank you

Then some appropriate commands {twisted from my last email}:

as root on the cvs_server:
edit /etc/group and add a group for your cvs work, i.e. add a line similar to the one of the following:
#if you choose to use users group,
# then substitute
# users where you see sadiascvsgroup below
chown sadia:sadiascvsgroup /appl/src/cvs/

Here sadia can be  root on the server machine ?
and can sadia be root on client machines (for workstations)?


then as sadia on cvs_server:
cd /appl/src/cvs/
mkdir JavaAppl
pwd #assumption it returns /appl/src/cvs/
export CVSROOT=/appl/src/cvs/JavaAppl
cvs init
mkdir JavaAppl/projectdir
chown :sadiascvsgroup JavaAppl/projectdir
chmod g+rws JavaAppl/projectdir
#you'll want to tighten up security on the following directory later.
chown :sadiascvsgroup JavaAppl/CVSROOT
chmod g+rws JavaAppl/CVSROOT

then as sadia on a_workstation:
export CVSROOT=:ext:cvs_server:/appl/src/cvs/JavaAppl
export CVS_RSH=ssh
cvs checkout projectdir
date > projectdir/mydate
cvs add projectdir/mydate
cvs commit -m"a comment" projectdir/mydate

as user1 on another_workstation:
export CVSROOT=:ext:cvs_server:/appl/src/cvs/JavaAppl
export CVS_RSH=ssh
cvs checkout projectdir

Thank you

Todd Denniston
Crane Division, Naval Surface Warfare Center (NSWC Crane)
Harnessing the Power of Technology for the Warfighter

reply via email to

[Prev in Thread] Current Thread [Next in Thread]