[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

repo manipulation

From: Marko Käning
Subject: repo manipulation
Date: Tue, 19 Aug 2008 13:48:28 +0200 (CEST)


I tried to simply copy a module from one of my repos into another one, 
hoping that it would not cause trouble, like this:

Repo1: /repos/old/CVSROOT
Repo2: /repos/new/CVSROOT

cp /repos/old/CVSROOT/module /repos/new/CVSROOT

As a result I was able to check out my module using Repo2.

It worked... So far so good...

But when I tried to convert Repo2 to mercurial the convert operation 
wouldn't do anything, just stop witout comment. Dangling somewhere...

So, I guess, simply copying a module from Repo1 to Repo2 is ILLEGAL.

I thought that it might be connected to the val-tags file in 
/repos/new/CVSROOT/CVSROOT, which is why I copied a missing tag from 
old module into there. But to no avail. Conversion would still stop for 

So I ask myself. Am I totally messing up the CVS repo itself with my 
simple drag and drop here? (Though I can't imagine, since there is not 
much more in /repos/new/CVSROOT/CVSROOT to consider!)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]