[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: repo manipulation

From: Todd Denniston
Subject: Re: repo manipulation
Date: Tue, 19 Aug 2008 09:29:02 -0400
User-agent: Thunderbird (X11/20080707)

Marko Käning wrote, On 08/19/2008 07:48 AM:

I tried to simply copy a module from one of my repos into another one, hoping that it would not cause trouble, like this:

Repo1: /repos/old/CVSROOT
Repo2: /repos/new/CVSROOT

cp /repos/old/CVSROOT/module /repos/new/CVSROOT

Assuming we are talking about
$CVSROOT/CVSROOT/module , where $CVSROOT is the CVSROOT variable in your environment, and the directories/files listed in that file exist in both repositories, then it should work, though IIRC you should not do it that way... the files in that directory are CVS controlled.

export CVSROOT=/repos/new/
cvs checkout CVSROOT
cp /repos/old/CVSROOT/module .
cvs commit

{I am almost betting you are going to send another message indicating you were talking more about $CVSROOT/MyVersionControlledDataDirectory instead of the $CVSROOT/CVSROOT/module module name control file, but I am going to make you send it, i.e., if you meant something other than $CVSROOT/CVSROOT/module you should have not have abstracted as much.}

As a result I was able to check out my module using Repo2.

It worked... So far so good...

But when I tried to convert Repo2 to mercurial the convert operation wouldn't do anything, just stop witout comment. Dangling somewhere...

did your convert work BEFORE you did the copy?
Have you asked the mercurial convert program author for help?

So, I guess, simply copying a module from Repo1 to Repo2 is ILLEGAL.

I thought that it might be connected to the val-tags file in /repos/new/CVSROOT/CVSROOT, which is why I copied a missing tag from old module into there. But to no avail. Conversion would still stop for mercurial.

So I ask myself. Am I totally messing up the CVS repo itself with my simple drag and drop here? (Though I can't imagine, since there is not much more in /repos/new/CVSROOT/CVSROOT to consider!)

{Todd is still wishing that they had named the $CVSROOT/CVSROOT/ directory something a little less confusing like: $CVSROOT/CVSCONTROL/ }

Todd Denniston
Crane Division, Naval Surface Warfare Center (NSWC Crane)
Harnessing the Power of Technology for the Warfighter

reply via email to

[Prev in Thread] Current Thread [Next in Thread]