[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS diff and loginfo

From: Tommy McNeese
Subject: CVS diff and loginfo
Date: Mon, 25 Aug 2008 13:15:29 -0400



I'm trying to get  a cvs diff inside of a script that's called from loginfo. I've tried both the script that I wrote and log_accum from cvs/contrib but they both produce the same problem, which is on certain files the cvs diff can not find the file being diffed. It reports the error: cvs diff: cannot find blah.txt


I'm using cvs version 1.11.22 on both the client and the server. I'm using pserver. I've tried running pserver on a Fedora 8 and Fedora 9 machine, with the same results. I added debug code, into the script that gets called from loginfo, to print out the contents of the temporary directory that cvs creates during a commit, and the file that was commited is not listed in there. It appears there is a race issue, the file is getting deleted before loginfo is called.


Is this a known issue? I've looked on web and this mailing list and did not find a similar problem. If I run the cvs diff command outside of the script, it works fine.


This problem does not happen on every file.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]