[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

missing files after cvs checkout

From: David Shrader
Subject: missing files after cvs checkout
Date: Wed, 11 Aug 2010 15:54:41 -0600
User-agent: KMail/1.13.5 (Linux/; KDE/4.4.5; x86_64; ; )

Hello All,

I have run into an issue that has stumped everyone I work with that uses CVS, 
so I thought I would present it to the larger CVS community.

In a code project that I have just been asked to help out, certain files fail 
to be checked out during a checkout or update. The only way to get these files 
is to check them out specifically, which is rather annoying. For example,

cvs -d <repo> co -P <directory>

checks out all but six of the needed files. Without these files, compilation of 
course fails. I have tried the following:

cvs update -dP

This fails to get the required files. I have tried this command both in the top 
level directory and the directory that the files should reside in, and both 
fail to get the files. The only way to get the files is to run the following 
each file:

cvs update -dP <path>/<file>

I can use 'co' instead of update and can get the same result. Before getting 
the file, I can successfully get the status of the file by using 'cvs status 
<path>/<file>'. There are no sticky dates or tags associated with any of the 

Does anyone understand what might be going on? What do we need to do to get 
the "missing" files working with a regular checkout?

One piece of information that might be helpful is that all six of the files 
were added later to the project. They were not part of the initial check-in 
(the team only recently adopted CVS, so the code was quite mature by the time 
of initial creation of the repository). As far as we can tell, every file that 
was added after the initial check-in exhibits this same behavior. Any 

Thank you for any and all help!
David Shrader
Los Alamos National Lab
HPC: System Integration

reply via email to

[Prev in Thread] Current Thread [Next in Thread]