[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

CVS Entries

From: Jonathan Rosenberg
Subject: CVS Entries
Date: Wed, 24 Aug 2011 10:44:36 -0400


I am really very new to CVS (a day or two), and have an issue.  I inherited
a web environment, and they use CVS (Version 1.11.22) to get the perl code
to the web servers (in /var/www/cgi-bin/<sitename>) form the staging
server.  The trouble is that yesterday when the developer updated the code
on the web server, he got messages saying the files were no longer in the
repository.  It then deleted them from the web server.

We rsynced form the staging server to the web servers to get the site going
again.  After that, I tried to do a "cvs update -Pd -r version application",
but it said that the files were in the way (I don't have the exact error for
that).  To fix that, I had to delete all the files completely (leaving the
CVS directory only), and then run the cvs update again.  Then I was able to
sync the files.

When I tried to run the cvs update a bit later for another new version
however, I get this error:

working in /var/www/cgi-bin
cvs update: cannot open CVS/Entries for reading: No such file or directory
cvs [update aborted]: no repository

I have not been able to figure out how to fix this.

Some further information to help out.  There is another CVS folder in the
/var/www/cgi-bin directory that is working just fine.  It comes from the
same source server too.

Thank you for any help you can provide.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]