[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: How to fix "no such user" problem

From: H Brydon
Subject: Re: How to fix "no such user" problem
Date: Mon, 19 Aug 2013 21:01:52 -0500

The config file is lengthy and mostly default. The non-blank non-commented lines of interest that seem to be non-default are:

# Set `UseNewInfoFmtStrings' to `no' if you must support a legacy system by
# enabling the deprecated old style info file command line format strings.
# Be warned that these strings could be disabled in any new version of CVS.

and the cvspserver file is less wordy:
address@hidden:/etc/xinetd.d$ cat cvspserver
service cvspserver
       port        = 2401
       socket_type = stream
       protocol    = tcp
       wait        = no
       user        = root
       passenv     = PATH
       server      = /usr/bin/cvs
       server_args = -f --allow-root=/cvs  pserver
#       xxx_server_args = -f --allow-root=/media/ddrive/cvs  pserver

My repository is on a separately mounted drive at /cvs, which was moved from /media/ddrive/cvs during a disk upgrade. FWIW the problem behavior happened with the old repo location as well. The /cvs directory is on an NTFS partition. I don't think I have any controversial software running on it. The main products I have are cvs, samba, svn client, Anjuta, Oracle java 7 (6 was hopefully removed), Eclipse and probably 4 or 5 others that I've forgotten about.

After sending the message below, I did several more reboots, and was able to get it to respond... but I want to fix the problem properly if anybody has ideas.

"Arthur Barrett" <address@hidden> wrote in message news:address@hidden

By default PServer authentication is a 'simple' text lookup with a
passwd file in CVSROOT.

However you can also set up 'SystemAuth' in which case a system call is
used, or you could be using something more complex still.

Please send the CVSROOT/config file and the /etc/xinetd.d/cvspserver


Arthur Barrett

-----Original Message-----
org] On Behalf Of H Brydon
Sent: 16 August 2013 03:23
To: address@hidden
Subject: How to fix "no such user" problem

Howdy - I have used cvs for several years, and have it set up
on an Ubuntu
linux box (ie. the linux box is the cvs server with the
repository, via
pserver) that has mostly worked fine for the interval.  I use
cvs (ie.
client) mostly from my Windows machine, but also from the
server and several
other linux machines (Mint, Raspberry Pi/Debian wheezy).  I
have had problems with the cvs server where connections to it will
sporadically give "no such user" errors.  I have found that a
reboot fixed
the problem, and when this happens, it happens 'forever'
until I reboot the
machine.  I am now in a situation where I am getting the "no
such user"
problem permanently, and reboots are not fixing it.  I
believe I have the
config details correct since it has worked 'mostly' properly
for several
years.  Any ideas?

I have rebooted several times today, without the reboot
resurrecting cvs.  I
also tried "sudo /etc/init.d/xinetd restart" but it has never
worked (even
when the reboot did).

[logged into the Ubuntu machine (the cvs server) as user 'harvey']

address@hidden:~$ sudo netstat -tap | grep cvs
[sudo] password for harvey:
tcp        0      0 *:cvspserver            *:*

address@hidden:~$ printenv

address@hidden:~$ cvs version
Client: Concurrent Versions System (CVS) 1.12.13-MirDebian-8
Fatal error, aborting.
harvey: no such user

address@hidden:~$ cvs -d :pserver:address@hidden:/cvs version
Client: Concurrent Versions System (CVS) 1.12.13-MirDebian-8
Fatal error, aborting.
harvey: no such user

address@hidden:~$ cvs -d :local:/cvs version
Concurrent Versions System (CVS) 1.12.13-MirDebian-8 (client/server)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]