[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS Checkout Fails But Module Exists

From: Bryan Batten
Subject: Re: CVS Checkout Fails But Module Exists
Date: Thu, 29 Aug 2013 09:09:15 -0700
User-agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:17.0) Gecko/20130801 Thunderbird/17.0.8

Hey Arthur,

Thanks for the reply and interest in my problem. Here is the script output of the three commands you requested:

Script started on Thu Aug 29 08:35:08 2013
]2;address@hidden - /home/bryan[1] bryan: !503
bash: !503: event not found
[1] bryan: cvs -ttt co -p FTPsites
  -> main: Session ID is 100521F6A4342F8EA9D
  -> Name_Root ((null), (null))
  -> parse_cvsroot (/usr/src/cvsroot)
  -> walklist ( list=0x7fa6310c4c60, proc=0x7fa630e36d10, closure=(nil) )
  -> main loop with CVSROOT=/usr/src/cvsroot
  -> parse_config (/usr/src/cvsroot)
  -> new_config ()
  -> parse_info() examining line: `UseNewInfoFmtStrings=yes'
  -> readBool (/usr/src/cvsroot/CVSROOT/config, UseNewInfoFmtStrings, yes)
  -> Read 0 for UseNewInfoFmtStrings
  -> my_module (FTPsites, Updating, NULL, NULL)
cvs checkout: cannot find module `FTPsites' - ignored
  -> walklist ( list=0x7fa6310c4c60, proc=0x7fa630e36d10, closure=(nil) )
  -> Lock_Cleanup()
  -> remove_locks()
  -> Simple_Lock_Cleanup()
[2] bryan: cvs rls
[3] bryan: cvs rls FTPsites
cvs rls: cannot find module `FTPsites' - ignored
]2;address@hidden - /home/bryan[4] bryan: exit

Script done on Thu Aug 29 08:35:50 2013

To answer your other questions:

The file /usr/src/cvsroot/CVSROOT/modules consists entirely of comments.

The file 'FTPsites' is a plain ASCII text file. I chose it purely to serve as an example. So far, the problem has occurred with *every* file I've attempted to check out.

I looked at the thread in Google Groups about file corruption while tagging. Let me save what seems liable to exposure, then try it. I'll follow through with an email on results.

I actually have switched CVS back to the 64 bit version, after having tried squeeze:i386, squeeze:amd64, wheezy:i386:, and back to wheezy:amd64. I've also tried the standard (wheezy:amd64) version using a backup of /usr/src/cvsroot made prior to upgrading to wheezy and converting to amd64.

Full disclosure: I ran into a *lot* of problems converting from i386 to amd64. The system is basically functional (I'm using it to write this email), but I think the cause of this problem is rooted in some subtle environmental inconsistency more than CVS itself.

Again, thanks a lot.

On 08/28/13 16:52, Arthur Barrett wrote:

Trace?  "cvs -ttt co -p FTPsites"

What's in your CVSROOT/modules file?

What is 'FTPsites' - a file/directory/link/module?

What result does 'cvs rls' give? And 'cvs rls FTPsites' ?

Also see the recent thread 'Re: cvs corrupts file while tagging' (a
bug report about cvs 1.12 x32 builds on x64 linux servers0.  The bug
has not been confirmed but maybe you should either test it or switch
back to the x64 build.


Basically, if I've stopped walking, you can pretty much tell I'm
chewing gum.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]