[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS Checkout Fails But Module Exists

From: Bryan Batten
Subject: Re: CVS Checkout Fails But Module Exists
Date: Sat, 31 Aug 2013 09:44:34 -0700
User-agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:17.0) Gecko/20130801 Thunderbird/17.0.8

Hi Arthur,

As a followup, I tried the following without cd'ing away from the current directory:
[6] bryan: blah=`cat CVS/Root`
[7] bryan: blot=`cat CVS/Repository`
[8] bryan: echo $blah
[9] bryan: echo $blot
[10] bryan: cvs -d $blah co -p ${blot}/FTPsites
It worked like a charm, and the content of "FTPsites" scrolled down the screen.

I considered the possibility of a permission problem. First, I compared what I have now with that of a backup made in June. Other than showing the change in my default umask from 0022 to 0077, they are the same. Here are the current permissions:
drwxr-xr-x 8 root root 4096 Aug 31  2011 /home/
drwx--x--x 134 bryan projects 8192 Aug 31 08:37 /home/bryan/
drwx--s--x 2 bryan users 4096 Aug 28 08:54 /home/bryan/CVS/
-rw------- 1 bryan users 640 Aug 28 08:54 /home/bryan/CVS/Entries
-rw------- 1 bryan users   6 Jun 23  2007 /home/bryan/CVS/Repository
-rw------- 1 bryan users  17 Jun 23  2007 /home/bryan/CVS/Root
I tried changing the permissions on CVS/ to remove 'set ID on execute", and change those of Entries, Repository, and Root from 600 to 644. Checkout still fails with the same error message, so I backed out the permissions changes.

Let me know what else I should try to provide information on my problem, and thanks again.

On 08/29/13 19:22, Arthur Barrett wrote:
Basically, if I've stopped walking, you can pretty much tell I'm chewing gum.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]