[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: CVS Checkout Fails But Module Exists

From: Bryan Batten
Subject: Re: CVS Checkout Fails But Module Exists
Date: Sun, 01 Sep 2013 18:15:42 -0700
User-agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:17.0) Gecko/20130801 Thunderbird/17.0.8

Hey Arthur,

Thanks very much for delving into this issue for me. Going about development without having full CVS functionality is not an option for me, so I've been pretty much at a standstill for the last week or so. I now have enough information that I can work around this particular item.

I think what I'll do is float it as a bug in Debian Wheezy and see what happens. Having to do the extra typing to tack on a module component to the checkout is a PITA.

On 09/01/13 16:48, Arthur Barrett wrote:
If you want to 'checkout':
    cvs co -d FTPsites bryan/FTPsites

Why didn't your original checkout work? Let's have a look:

    cvs co -p FTPsites

This command tells CVS to checkout the module FTPsites.  There is no
such module.  The module is: bryan/FTPsites

Based on your observations, I tried this (while in my home directory ~/bryan):

cvs co -p bryan/FTPsites

and that worked too. Also, this works:

cvs up -p FTPsites

I now recall that previously, things like "co FTPsites" worked fine if I was actually in the module directory, and would fail otherwise, which is what I expected. If I recall correctly, if I was not in the module directory, I needed to specify the relative or full path name to the directory containing the file in question.

So it looks to me like the earlier CVS inferred the the module from `pwd` - or possibly from $(basename $(pwd)).

Why did this change after the upgrade?  It's either a bug before or
after.  Either CVS was wrong to 'use' CVS/Repository to find the PATH to
the module before the upgrade, or CVS is wrong to ignore the
CVS/Repository PATH after the upgrade.

To me, the bug is an introduced incompatibility. Behavior has changed in a way that makes this version of "co" incompatible with previous versions.


Thanks again for your efforts,
Basically, if I've stopped walking, you can pretty much tell I'm chewing gum.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]