[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AC_PROG_LIBTOOL causes problems for automake?

From: Daniel Katz
Subject: AC_PROG_LIBTOOL causes problems for automake?
Date: 21 May 2001 18:31:30 -0400
User-agent: Gnus/5.0808 (Gnus v5.8.8) Emacs/20.7


        I am trying to use automake, autoconf, and libtool together,
and have run into the following problem.  I put AC_PROG_LIBTOOL into
my and run the following sequence

$ libtoolize
$ aclocal
$ autoconf
$ automake --foreign -a

and get the message:

Core/ library used but `LIBTOOL' not defined in `'

where Core is a subdirectory of the project and line 8 of
Core/ is the first LTLIBRARIES primary.

I then tried changing to AM_PROG_LIBTOOL, which worked when I copied
the contents of libtool.m4 into acinclude.m4.  Nevertheless, I
understand that AM_PROG_LIBTOOL is deprecated in favor of
AC_PROG_LIBTOOL, and am wondering what the issue is.  I have not found
anything in the documentation of automake, autoconf, or libtool which
seems to shed light on this.

I am using libtool 1.4, automake 1.4-p1, and autoconf 2.13 on Debian
GNU/Linux system with a 2.2.18 kernel.



P.S.  I hope this is the right forum for the question -- since it
seems to involve the whole libtool-automake-autoconf trio, it was a
bit hard to tell.

P.P.S.  Sorry if this is a FAQ -- the archives to this list don't seem
to be easily searchable.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]