[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Shared library with U suffix not installed

From: Lawrence, David (STEI)
Subject: Shared library with U suffix not installed
Date: Fri, 25 May 2001 12:59:56 -0700

I am new to the Autotools and so may have overlooked the obvious, but I
would appreciate any help/guidance you might be able to provide.  I have
reviewed the Autoconf, Automake and Libtool manuals and read the New Riders
"Gnu Autoconf, Automake and Libtool" book.

I am using Autoconf 2.13 and Automake 1.4 on Red Hat 7.0 with the glibc
fixes.  I upgraded to Libtool 1.4 from one of the Gnu mirrors based on
messages I read in the archives for this mailing list.

I am porting an existing project and its directory structure to the

The project being ported creates daemons that have a programming interface
accessed through shared libraries.  Other developers will be accessing the
daemons through these shared libraries, so they need to be able to link the
shared libraries and use the project's global header files to do so.

In addition, there is a static library used to provide helper functions to
the shared libraries and daemons that is not intended to be accessed by

The project directory structure is similar to the following with my
understanding of where convention would have the output installed:

     staticlib  (for building daemonx and sharedlibx ... not to be
          include    (for building daemonx and sharedlibx ... not to be
     daemon1    installed in $(sbindir)
     sharelib1  installed in $(pkglibdir)
     sharelib2  installed in $(pkglibdir)
     sharelib3  installed in $(pkglibdir)
     include    installed in $(pkgincludedir)
          sharelib4  installed in $(pkglibdir)
          daemon2  installed in $(sbindir)

Two of the sharedlibs are dependent on other shared libs.  (All of the
shared libs and the daemons use the staticlib).  

What is the correct way to instruct the Autotools to make a shared library
that references another shared library?  For example, in the directory
structure above sharelib3 needs to reference sharelib1.  I have tried
various combinations in LDADD and LIBADD ... trying to follow error messages
from Automake ... without success.  I have also tried an LDFLAGS option
(-l../sharedlib/, but that creates an LD error that it can't
find the library.  The shared libraries have not been installed on the
system.  I'm trying to get a succesful build first.


Thanks, in advance, for any help you can provide.

David Lawrence

reply via email to

[Prev in Thread] Current Thread [Next in Thread]