[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Shared library with U suffix not installed

From: Robert Boehne
Subject: Re: Shared library with U suffix not installed
Date: Fri, 25 May 2001 16:36:48 -0500

"Lawrence, David (STEI)" wrote:
> I am new to the Autotools and so may have overlooked the obvious, but I
> would appreciate any help/guidance you might be able to provide.  I have
> reviewed the Autoconf, Automake and Libtool manuals and read the New Riders
> "Gnu Autoconf, Automake and Libtool" book.
> I am using Autoconf 2.13 and Automake 1.4 on Red Hat 7.0 with the glibc
> fixes.  I upgraded to Libtool 1.4 from one of the Gnu mirrors based on
> messages I read in the archives for this mailing list.
> I am porting an existing project and its directory structure to the
> Autotools.
> The project being ported creates daemons that have a programming interface
> accessed through shared libraries.  Other developers will be accessing the
> daemons through these shared libraries, so they need to be able to link the
> shared libraries and use the project's global header files to do so.
> In addition, there is a static library used to provide helper functions to
> the shared libraries and daemons that is not intended to be accessed by
> others.
> The project directory structure is similar to the following with my
> understanding of where convention would have the output installed:
> project
>      staticlib  (for building daemonx and sharedlibx ... not to be
> installed)
>           include    (for building daemonx and sharedlibx ... not to be
> installed)
>      daemon1    installed in $(sbindir)
>      sharelib1  installed in $(pkglibdir)
>      sharelib2  installed in $(pkglibdir)
>      sharelib3  installed in $(pkglibdir)
>      include    installed in $(pkgincludedir)
>      subdir
>           sharelib4  installed in $(pkglibdir)
>           daemon2  installed in $(sbindir)
> Two of the sharedlibs are dependent on other shared libs.  (All of the
> shared libs and the daemons use the staticlib).
> What is the correct way to instruct the Autotools to make a shared library
> that references another shared library?  For example, in the directory
> structure above sharelib3 needs to reference sharelib1.  I have tried
> various combinations in LDADD and LIBADD ... trying to follow error messages
> from Automake ... without success.  I have also tried an LDFLAGS option
> (-l../sharedlib/, but that creates an LD error that it can't
> find the library.  The shared libraries have not been installed on the
> system.  I'm trying to get a succesful build first.
> Suggestions?


It's a bit hard to debug without the exact shell commands and their
For the static library, you'll want to use a Libtool convience library,
for the others a normal Libtool library.  Post the exact commands and
errors that you get and perhaps we can help.



Robert Boehne             Software Engineer
Ricardo Software   Chicago Technical Center
TEL: (630)789-0003 x. 238
FAX: (630)789-0127
email:  address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]