[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Line length limitations

From: libtool
Subject: Line length limitations
Date: Sun, 27 May 2001 02:30:00 -0500
User-agent: Mutt/1.1.12i

While building the latest version of Ethereal 0.8.18 with a long
--prefix, I ran into what appeared to be a limitation in the
command-line length of Solaris 2.6/SPARC /bin/sh. So, I upgraded the
version of libtool used therein to MLB hoping Robert's
piecewise-linking enhancements would work around this problem. I had
the same error. Turns out the problem was with sed. Solaris
2.5.1-8/SPARC have the same problem. GNU sed does not. Here's the
snippet from libtool 1.4 that was giving the problem:

  # Now compile the dynamic symbol file.
  $show "(cd $output_objdir && $CC 
  $run eval '(cd $output_objdir && $CC 
-c$no_builtin_flag$pic_flag_for_symtable"$dlsyms")' || exit $?

  # Clean up the generated files.
  $show "$rm $output_objdir/$dlsyms $nlist ${nlist}S ${nlist}T"
  $run $rm "$output_objdir/$dlsyms" "$nlist" "${nlist}S" "${nlist}T"

  # Transform the symbol file into the correct name.
  compile_command=`$echo "X$compile_command" | $Xsed -e 
  finalize_command=`$echo "X$finalize_command" | $Xsed -e 

The problem arises with the assignment for compile_command. I get:
  Output line too long.
  Output line too long.

The following platforms don't have the same sed limitation (or at
least their limitation is greater than Solaris): HP-UX 10.20, 11.00,
Tru64 UNIX 4.0D, 5.0, IRIX 6.2, 6.5, AIX 4.3.2.

Should the command to find the maximum command-line length take the
above into consideration? And, if it did, would it have helped?

albert chin (address@hidden)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]