[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

-nostdlib in kde libtool branch?

From: Jack Howarth
Subject: -nostdlib in kde libtool branch?
Date: Mon, 10 Sep 2001 09:41:58 -0400 (EDT)

   I noticed that the libtool in kdebase 2.2.0 (which
I am told is from a special multilanguage branch of
libtool) uses the -nostdlib flag when building shared
libs. This requires libtool to be able to properly
identify all required libs from gcc -v for linking
a shared lib. Unfortunately libtool, in kdebase at
least, is unable to figure this out even with the
specs file for gcc using -lgcc rather than libgcc.a%s
for *libgcc. I tried both and in neither case did
libtool link in -lgcc. 
   It would be nice if we could have a test case
for this problem in the make check of libtool.
I would imagine we could just have a shared lib
compiled by libtool which will require a common
libgcc symbol. When the shared lib is built with
libtool it should be passed -nostdlib to expose
this bug. How you do the check on this I am less
certain since libgcc is static we can't use ldd
to look for it. Perhaps we could just use nm 
and grep for the symbol required from libgcc and see
if it is undefined? Thanks in advance for considering
this. In kdebase I worked around this issue for now
by hacking admin/ to always link against -lgcc
when -nostdlib is passed to libtool to link a shared
ps Of course none of this addresses the bug itself
but the problem only is triggered at the moment in
kdebase because of the use of the -nostdlib flag
with libtool.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]