[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Darwin & Dynamic modules

From: Guido Draheim
Subject: Re: Darwin & Dynamic modules
Date: Sat, 15 Sep 2001 03:28:40 +0200

Max Horn wrote:
> OK, I think I  just found out that this is the reason modules are not
> built right on darwin:
> # Commands used to build and install a shared archive.
> archive_cmds="\$CC \$(test \\"x\$module\\" = xyes && echo -bundle ||
> echo -dynamiclib) \$allow_undefined_flag -o \$lib \$libobjs
> \$deplibs\$linker_flags -install_name \$rpath/\$soname \$verstring"
> Changing the two \\" to \" worked nicely for me. Libtool, with this
> change, produces modules now when asked for them.

it's an old bug - you may want to use this ac-macro to fix it in your project:

cvs libtool has a changelog entry that makes me assume that the zsh overquoting
problem has been solved somehow. (/bin/sh on darwin is usually a zsh) but I am
not that sure about it. Others have to comment on that. With the above patch
tagged into (after the libtool macros) makes the compilation 
process to just do what it is supposed to do - to create .so files. If you get
to create .dylib's then please tell me how it can be done, okay? TIA...

-- guido
(sorry for being this late but had stopped service for a few days)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]