[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Darwin once more

From: Max Horn
Subject: Darwin once more
Date: Sat, 22 Sep 2001 01:35:36 +0200

Hi there,

two problems with libtool HEAD-cvs:

1) with regard to dlpreopen, there is yet another quoting problem. The libtool file generated from HEAD-cvs contains three lines like this:

global_symbol_to_c_name_address="sed -n -e 's/^: \([^ ]*\) \$/ {\\"\1\\", (lt_ptr) 0},/p' -e 's/^[BCDEGRST] \([^ ]*\) \([^ ]*\)\$/ {\"\2\", (lt_ptr) \&\2},/p'"

Note the bad \\" in there ... I do not enough to give a fix for libtool.m4, though :/ BUt if there is anything i can do for testing, let me know. Oh yeah, fixing that problem in libtool manually makes libtool pass the various demo-* tests, which otherwise fail.

2) in libtool.m4, HEAD cvs, line 4685, look like this:

      _LT_AC_TAGVAR(whole_archive_flag_spec, $1)='-all_load $convenience'

This particular line, as I know realize, is the source of various problem I have with libtool on darwin. It does not make any sense to me, as the -all_load command does not take any parameters, too. The current line does cause problems with linking frequently, though. To quote the ld man page on OS X:

              Loads  all  members  of  static  archive libraries.
              This  option  does  not  apply  to  dynamic  shared

Fine; but if you just specify $conveniance there, then in various cases it will pass the libs in there *twice*, which may work on other systems (or may not :), but on darwin it definitly fails, the compiler does not like this behaviour.

So I tried just dropping the $conveniance part, and that worked fine in one test case; but I think somebody should think about this who knows more.

Max Horn
Software Developer

email: <mailto:address@hidden>
phone: (+49) 6151-494890

reply via email to

[Prev in Thread] Current Thread [Next in Thread]