[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

is there an official libtool patch for the "relinking" problem

From: pauljohn
Subject: is there an official libtool patch for the "relinking" problem
Date: Wed, 21 Nov 2001 23:04:25 -0600

When I try to use the RPM system to build programs with
libtool-1.4.2, I run into the problem that usage of 
make package=whatever install
confuses libtool and an attempted to relink *.la files fails
because it can't find the required files. 

In the archives of this and other lists, I have seen several
proposed solutions, and I've actually applied a couple of them,
one worked, one caused all libtool-based programs to fail!  So I
started to wonder if there is an "endorsed" patch for
libtool-1.4.2.  I have built libtool from your cvs archive and
it does work, but I'm afraid it has other consequences (bugs?)
that might hurt me and I'd just as soon stick with your release

In case you wondered, the patch I tried which seemed to work was

---      Fri May 11 05:34:59 2001
+++   Thu May 31 02:14:09 2001
@@ -1862,6 +1862,7 @@
              # We cannot seem to hardcode it, guess we'll fake
+             test -d $ladir/.libs && add_dir="$add_dir

I tried to apply DeJong's patch from cvs to the 1.4.2 version
and libtool did compile, but the programs built with it
segfault, saying things like they can't find xmalloc and such,
so maybe I didn't get the diff correct or maybe that patch is
only for libtool-cvs.

I have seen yet a third approach to the problem in the Mandrake
linux package for libtool that is recently announced.

Paul E. Johnson                       email: address@hidden
Dept. of Political Science  
University of Kansas                  Office: (785) 864-9086
Lawrence, Kansas 66045                FAX: (785) 864-5700

reply via email to

[Prev in Thread] Current Thread [Next in Thread]