[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: generated libtool on debian/unstable always broken

From: Dan Kegel
Subject: RE: generated libtool on debian/unstable always broken
Date: Tue, 28 Jan 2003 22:01:37 -0800

Hah.  I bet it's a quoting
problem; it seems newer autotools silently f**ks up 
on improperly quoted sources that worked fine with older
autotools.  IMHO this is a usability bug in newer autotools.

I believe one or the other of the following patches
dealt with this particular problem for one package (kaffe),
though unfortunately they didn't mention the fact too clearly:

-----Original Message-----
From: Xavier Bestel
To: address@hidden
Sent: 28.01.2003 11:05
Subject: generated libtool on debian/unstable always broken


I have a debian/unstable system which consistently always generates
broken libtool, from every package I tried (a lot of them).

I tried reinstalling all packages which could be more or less related
(libtool, auto*, libc6, *utils, sed, etc. a few hundreds packages !) or
changing automake versions, it didn't do anything. I verified md5sums,
they are Ok.

Let's take the package gaim-0.59.7 for example. The build process fails

make[1]: Entering directory `/home/xav/xx/gaim-0.59.7/sounds'
/bin/sh ../libtool --silent --mode=link gcc  -g -O2 -I/usr/local/include
-I/opt/include -I.. -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
-I/usr/lib/glib/include -I/usr/X11R6/include
-I/usr/include/gdk-pixbuf-1.0 -I/usr/include/gtk-1.2
-I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include
-o au2h  au2h.o  -lnsl
../libtool: line 4615: syntax error near unexpected token `fi'
../libtool: line 4615: `        fi'

(One remark fisrt, if I copy /usr/bin/libtool over the generated
libtool, then the build process proceeds fine. So /usr/bin/libtool is

Now, let's look at the culprit around line 4615:

        # Install the pseudo-library for information purposes.
        name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
4612    ed library.
          test -n "$library_names" && $echo "$modename: warning:
\`$file' was not linked with \`-export-dynamic'"
4615    fi

        dir=`$echo "X$file" | $Xsed -e 's%/[^/]*$%%'`
        test "X$dir" = "X$file" && dir=.

        if test -f "$dir/$objdir/$dlname"; then
          $echo "$modename: cannot find \`$dlname' in \`$dir' or
\`$dir/$objdir'" 1>&2
          exit 1

        # Just add the directory containing the .lo file.
        dir=`$echo "X$file" | $Xsed -e 's%/[^/]*$%%'`
        test "X$dir" = "X$file" && dir=.

Notice the line 4612, it seems totally weird. The line just before
corresponds to the line 4618 of /usr/bin/libtool, and the line after
corresponds to the line 4942 of /usr/bin/libtool. Obviously there's a
part of the file missing.

The problem is I don't know anything about the libtool generation
process. I don't know how it is generated, with which config files etc.
I must have something broken somewhere on my root filesystem, this
situation is now some months old, nearly all autotools have been
upgraded and I still can't find what's the problem.

That drives me nuts.

Could someone help me to find the trouble maker ? Where should I look ?
Did someone already have that problem ?


Cc: me

Libtool mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]