[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Installing in a staging area

From: Charles Gagnon
Subject: Installing in a staging area
Date: Thu, 25 Sep 2003 09:25:25 -0400
User-agent: Mutt/1.4i


I am having a hard time installing apps in a staging area. What I am
trying to do is this:

 ./configure --prefix=/usr/local
 make prefix=/usr/local/staging/appname install

The purpose is to package everything in /usr/local/staging/appname
to be later installed in /usr/local on multiple systems. This use to
work but now, whenever I try I get:

libtool: install: error: cannot install `' to a 
directory not ending in /usr/local/lib/

I get the same error on multiple packages (Guile, GTK+, GLib, etc)
and I even tried different libtool versions (recent 1.4, 1.5 and the
head CVS for 1.5). I am currently on: (GNU libtool) 1.5a (1.1262 2003/09/21 12:50:47)

A lot of the applications seem to have the following version in
their source tree: (GNU libtool) 1.5 (1.1220.2.1 2003/04/14 22:48:00)

The only way I work around this is by using:

  make prefix=/usr/local/staging/appname install

which, unless I am mistaking, relinks all the libraries with the
/usr/local/staging/appname path. So I am probably gonna have
problems once I install in /usr/local/ correct?

Please help!

Charles Gagnon                   | My views are my views and they             | do not represent those of anybody
charlesg at        | but me.

   If a mime is arrested do they tell him he has the right to
        -- Dennis Miller

reply via email to

[Prev in Thread] Current Thread [Next in Thread]