[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Libtool should infer mode when running gcj

From: Thomas Fitzsimmons
Subject: Re: Libtool should infer mode when running gcj
Date: Tue, 06 Jul 2004 02:25:51 -0400

On Mon, 2004-07-05 at 23:45, Thomas Fitzsimmons wrote:
> Hi,
> We're trying to create Java shared libraries using libtool and gcj. 
> Unfortunately, libtool can't infer the compilation mode when given a gcj
> command.  We tried to use standard automake variables to define the
> libraries we were creating, but the result was compilation errors:
> if /bin/sh ../libtool --mode=compile gcj 
> --classpath=/home/fitzsim/sources/plugin-src/gcjwebplugin/src:../src 
> -I/home/fitzsim/install/include   -g -O2 -MT 
> gnu/gcjwebplugin/lib_gnu_gcjwebplugin_la-AppletSecurityManager.lo -MD -MP -MF 
> "gnu/gcjwebplugin/.deps/lib_gnu_gcjwebplugin_la-AppletSecurityManager.Tpo" -c 
> -o gnu/gcjwebplugin/lib_gnu_gcjwebplugin_la-AppletSecurityManager.lo `test -f 
> 'gnu/gcjwebplugin/' || echo 
> '/home/fitzsim/sources/plugin-src/gcjwebplugin/src/'`gnu/gcjwebplugin/;
>  \
> then mv -f 
> "gnu/gcjwebplugin/.deps/lib_gnu_gcjwebplugin_la-AppletSecurityManager.Tpo" 
> "gnu/gcjwebplugin/.deps/lib_gnu_gcjwebplugin_la-AppletSecurityManager.Plo"; 
> else rm -f 
> "gnu/gcjwebplugin/.deps/lib_gnu_gcjwebplugin_la-AppletSecurityManager.Tpo"; 
> exit 1; fi
> libtool: compile: unable to infer tagged configuration
> libtool: compile: specify a tag with `--tag'
> Shouldn't libtool infer --tag=gcj when gcj is the command?

It turns out these errors are caused by AC_PROG_LIBTOOL appearing before
AM_PROG_GCJ in  When I reordered them, everything worked
fine.  I've filed an automake bug for this since AM_PROG_GCJ should call
AC_BEFORE so that a warning is issued if these macros appear


reply via email to

[Prev in Thread] Current Thread [Next in Thread]