[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

libtool and /usr/local/lib

From: Geoff
Subject: libtool and /usr/local/lib
Date: Mon, 27 Sep 2004 08:16:43 +0100

Forgive me for a lengthy post to a developer list with
what is probably a naive user question.  I have tried my
distro list as well as an application list but with no

I have just upgraded libxml on this Slackware 9.1 box and
the libraries are now in the default /usr/loca/lib rather
than /usr/lib where they were before.  Before compiling /
installing the new libraries I removed the old ones and all
related files. xml-config and pkgconfig have been replaced
and accurately report the location of the new libraries.

Since upgrading I have tried to compile the current xine-
lib (xine-lib-1-rc6a) and more recently the vips image
processing library (vips-7.8.14), both of which use libtool
1.5.2.  In both cases configure completes successfully, but
compilation aborts with failure to find libxml.  In xine the
error is :

grep: /usr/lib/ No such file or directory
/bin/sed: can't read /usr/lib/ No such file
or directory libtool-nofpic: link: `/usr/lib/'
is not a valid libtool archive.

In vip the error is :

/bin/sh ../../libtool --mode=link gcc  -g -O2   -o vips 
vips.o -pthread ../../libsrc/ -L/usr/X11R6/lib
-L/usr/X11R6/lib -L/usr/lib -L/usr/lib -lMagick -ltiff
-lfreetype -ljpeg -lpng -lexif -ldpstk -ldps -lXt -lXext
-lSM -lICE -lX11 -lbz2 -lxml2 -lz -lpthread -lm
-L/usr/lib/pkgconfig -lpng -ltiff -lz -ljpeg    -lm -ldl
mkdir .libs libtool: link: cannot find the library

I xine I found that I could compile if I inserted colons in
the path I found under Compile-time system search path for
libraries sys_lib_search_path_spec="/lib /usr/lib
/usr/local/lib".  But that was just mindless tinkering on
my part and does not work for vip, whose equivalent path is
much longer :

/lib/i486-slackware-linux/3.2.3/ /lib/
/usr/lib/i486-slackware-linux/3.2.3/ /usr/lib/"

I know that I can work around these problems by making
symlinks for libxml from /usr/local/lib to to /usr/lib, but
I really want to understand why I am getting the error in
the first place.  I have many other libraries in
/usr/local/lib and libtool has never failed to find them

Google throws up only two instances similar to mine, one in
French and one in German, and, so far as I can tell, neither
was successfully resolved.

Any advice please?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]