[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Libtool 1.5.8 problems on OSX: ${wl} evaluation [#9382]

From: Peter O'Gorman
Subject: Re: Libtool 1.5.8 problems on OSX: ${wl} evaluation [#9382]
Date: Wed, 13 Oct 2004 13:34:34 +0900
User-agent: Mozilla Thunderbird 0.7.3 (Macintosh/20040803)

Gary V. Vaughan wrote:

Isn't the problem report -Wl,suppress vs suppress, rather than the wonky
${wl} in the $show?

I don't know. I awoke this morning fully convinced it was Friday (turned out to be Wednesday), so I may have misread :-). However, it worked for me just now when I tried it from the command line: peter% g++ -dynamiclib -single_module -Wl,-flat_namespace -Wl,-undefined -Wl,suppress -o .libs/libbaz.0.0.0.dylib .libs/baz.o .libs/libbaz.lax/libfoo.a/foo.o -install_name /Users/peter/libtool-1.5.10/tests/_inst/lib/libbaz.0.dylib -Wl,-compatibility_version -Wl,1 -Wl,-current_version -Wl,1.0

Ah, yes I have seen this too, now that you explain it. We need to figure out which $show is responsible, and make it into an eval $show...

It seems to be all over the place. When I moved things around so that we could build things in a directory containing a ~ I changed the way things were eval'ed for pretty much all the cmds. I guess I should do an eval $show anywhere I see a $show before a "$run eval"?

Gary, we need some tests without -no-undefined on platforms which support generating shared libraries with undefined symbols.

I'll submit a patch proposal presently.

Your "presently" is a lot faster than my "minute". Thanks.

Peter O'Gorman -

reply via email to

[Prev in Thread] Current Thread [Next in Thread]