[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Porting libtool to SkyOS

From: Robert Szeleney
Subject: Porting libtool to SkyOS
Date: Thu, 20 Apr 2006 16:33:16 +0200

Hi guys!

I recently started porting libtool to SkyOS. In general, libtool works just fine in SkyOS, but only for static libraries. So I want to update it to support shared libraries. (SkyOS uses a unix similar filesystem layout with most GNU tools available and uses the PE format for executable files).

Ok, I started by reading following documentation: As stated there, I added all SkyOS specific setting to libtool.m4 from the libtool-1.5.22 package. Unfortunately I don't know how to proceed. What must be done next? Just a simple ./configure;make;make check?  

I tried this, but it doesn't look like as if my changes were actually used. (only libtool.m4 has the new changes in it, no other file).
I then tried to use autoconf/automake, but this failed with error messages like: No proper invocation of AM_INIT_AUTOMAKE was found. I upgraded autoconf to 2.95c without success.

Running ./bootstrap also prints many autoconf errors.

Can anyone give me a few hints on how to actually "compile" and test the changes?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]