[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Porting libtool to SkyOS

From: Ralf Wildenhues
Subject: Re: Porting libtool to SkyOS
Date: Thu, 20 Apr 2006 16:40:43 +0200
User-agent: Mutt/1.5.11

Hi Robert,

* Robert Szeleney wrote on Thu, Apr 20, 2006 at 04:33:16PM CEST:
> I recently started porting libtool to SkyOS. In general, libtool works 
> just fine in SkyOS, but only for static libraries. So I want to update it 
> to support shared libraries.

> Ok, I started by reading following documentation: 
> As stated there, 
> I added all SkyOS specific setting to libtool.m4 from the libtool-1.5.22 
> package. Unfortunately I don't know how to proceed.

 ( ./bootstrap && ./configure && make && make check VERBOSE=x ) 2>&1 |
    tee log

and send the log.

> I tried this, but it doesn't look like as if my changes were actually 
> used. (only libtool.m4 has the new changes in it, no other file).
> I then tried to use autoconf/automake, but this failed with error messages 
> like: No proper invocation of AM_INIT_AUTOMAKE was found. I 
> upgraded autoconf to 2.95c without success.

2.59c should not be necessary, 2.59 is fine.

> Running ./bootstrap also prints many autoconf errors.

This is weird.  Let's see those errors.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]