[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

libtool + MinGW

From: Brendon Costa
Subject: libtool + MinGW
Date: Fri, 09 Jun 2006 23:58:24 +1000
User-agent: Thunderbird (Windows/20060516)

Hash: SHA1

Hi All,

        As part of my quest to get libtool and MSVC working together, i thought
i would first get libtool working with an example project on a few other
systems first. I have created this small example project to test using
static and shared libraries, DLOpened modules and applications that use
all these in normal modes + with the -all-static flag.

I am fine with getting it to work on my NetBSD box. I have been trying
to get it working on my Windows box using MinGW - GCC and libtool 1.5.22.

In this project i am issuing libtool commands through a shell script in
order to get an understanding of what needs to be done later when i
implement some jam rules that make use of libtool.

The attached file is a tarball that is a cut down version of the
project. It should however contain all files needed to run the script
successfully. There is also a script that i am using to build
this, and a results.txt file that shows the results from when i run the file.

Basically i cant seem to get dlpreopening to work with GCC. The linking
fails with multiply defined symbols of libltdl malloc and free functions
when i use the -all-static option to libtool along with the -dlopen
providing the dlopened module for preopening (Note i also tried using
- -dlpreopen)

Would someone be able to have a look at the script file and let me know
what i am doing wrong?

Thanks for the help.
Brendon Costa.

Note: To run the script, extract the tarball, change into the System
directory where you will find the script and execute it.

Version: GnuPG v1.4.2 (MingW32)


Attachment: System.tar.gz
Description: application/gzip

reply via email to

[Prev in Thread] Current Thread [Next in Thread]