libtool
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AW: libtool + MinGW


From: Duft Markus
Subject: AW: libtool + MinGW
Date: Mon, 12 Jun 2006 08:24:00 +0200

Hi!

Do you want to get it to work with the MinGW GCC, or with the MSVC toolchain 
(i.e. cl.exe, link.exe etc...) ? This makes a big difference, since libltdl is 
really useless with the MS toolchain.

I think we allready talked about wgcc, did we? ;o)

Regards, Markus 

-----Urspr√ľngliche Nachricht-----
Von: address@hidden [mailto:address@hidden Im Auftrag von Brendon Costa
Gesendet: Freitag, 9. Juni 2006 15:58
An: address@hidden
Betreff: libtool + MinGW

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi All,

        As part of my quest to get libtool and MSVC working together, i thought 
i would first get libtool working with an example project on a few other 
systems first. I have created this small example project to test using static 
and shared libraries, DLOpened modules and applications that use all these in 
normal modes + with the -all-static flag.

I am fine with getting it to work on my NetBSD box. I have been trying to get 
it working on my Windows box using MinGW - GCC and libtool 1.5.22.

In this project i am issuing libtool commands through a shell script in order 
to get an understanding of what needs to be done later when i implement some 
jam rules that make use of libtool.

The attached file is a tarball that is a cut down version of the project. It 
should however contain all files needed to run the script successfully. There 
is also a test.sh script that i am using to build this, and a results.txt file 
that shows the results from when i run the tests.sh file.

Basically i cant seem to get dlpreopening to work with GCC. The linking fails 
with multiply defined symbols of libltdl malloc and free functions when i use 
the -all-static option to libtool along with the -dlopen providing the dlopened 
module for preopening (Note i also tried using
- -dlpreopen)

Would someone be able to have a look at the script file and let me know what i 
am doing wrong?

Thanks for the help.
Brendon Costa.


Note: To run the script, extract the tarball, change into the System directory 
where you will find the script tests.sh and execute it.









-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (MingW32)

iD8DBQFEiX5iLSWCuZeiyS0RAlJtAKCw+DbXKIZ32hg9iJ17XucTV3VOmwCfaPx3
ly+Sa0k5Y8zL4LTrPLY/m00=
=JuTk
-----END PGP SIGNATURE-----




reply via email to

[Prev in Thread] Current Thread [Next in Thread]