[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problem with /usr/lib and /usr/lib64

From: Lynn F. Ten Eyck
Subject: Problem with /usr/lib and /usr/lib64
Date: Thu, 15 Feb 2007 23:15:32 +0000


Is there a version of libtool that is compatible with the 1.59 autoconf and with the x86_64 file system layout for 64-bit systems? Otherwise I will be making a fragile patch script for libtool, which is not an elegant solution to my problems . . .

I have been trying to install a large and complex graphics application on a Fedora Core 5 64-bit system (x86_64). This variant of Linux places 64-bit libraries in /usr/lib64, and 32-bit libraries in /usr/lib. Most of the required support packages for this application installed from source quite nicely, using ./configure && make && make install. However, the packages using OpenGL all failed. I found that the libtool-generated gcc commands for mode=link were incorrect.

Versions:  autoconf 1.59, automake 1.9.6, libtool  1.5.22
The problem was traced to the point where libtool was trying to hard- code the dynamic library names into the shared library; on this system it is done by directly inserting it into the list of loaded objects, thus: gcc (many options and object files) -L(some libraries) -lthis -lGL - lthat /usr/lib/ (more stuff)

Autoconf had previously found /usr/lib64/ and told libtool where to find it, so the "-lGL" picked up the correct library, but a different path list is used to locate the library for hard-coding the path.

I tried to fix the problem by stepping up to the latest releases of autoconf, automake, and libtool, but ran into some significant headaches since this is the first time I have had to get very deeply into this software. First, I had to upgrade the macros used since autoconf 1.61 is more picky than 1.59. Then I ran into some problems trying to make autoreconf find and use the local macros -- it kept losing them and breaking the configuration. I finally did a manual version of autoreconf and got a good configure file (I thought) but the final compilation commands were breaking on the names of the files containing the dependencies -- there was something strange going on about the .Tpo files that I did not have time to locate. I strongly suspect that these problems are due to the changes in the macro libraries and if I knew more about that I would not have these problems.

Lynn Ten Eyck

Lynn F. Ten Eyck, E. T. S. Walton Visiting Professor
UCD Conway Institute Office: S055 Conway University College Dublin Tel. +353 1 716-6845 Belfield, Dublin 4, Ireland email: address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]