[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Libtool error on HP-UX.

From: Tamer Embaby
Subject: RE: Libtool error on HP-UX.
Date: Wed, 27 Feb 2008 17:54:06 +0200


OK, I found the problem, I copied the latest libtool to the srclib/apr
and srclib/apr-util and recompiled (ran make) and it worked.


-----Original Message-----
From: address@hidden [mailto:address@hidden On Behalf Of Tamer Embaby
Sent: Wednesday, February 27, 2008 4:49 PM
To: address@hidden
Subject: Libtool error on HP-UX.

I'm trying to compile Apache 2.2.8 but failing with something that I
believe to be error on the generated "libtool" utility, or may be a
mistake from my side, but I'm not sure which.

Information about the system:
$ uname -a
HP-UX SPHINX B.11.23 U ia64 4017848671 unlimited-user license

$ gcc -v
Using built-in specs.
Target: ia64-hp-hpux11.23
Configured with: ../gcc/configure
Thread model: posix
gcc version 4.1.1

Apache 2.2.8 source from

Configured with:
$ export CC="gcc"
$ export CFLAGS="-mlp64"
$ ./configure --prefix=/apps/apache2.2 --with-included-apr

Everything went fine so far (I can include the output of the command if

The error:
$ make
... Lots of output ...
        /usr/bin/posix/sh /home/te/httpd-2.2.8/srclib/apr/libtool --silent 
--mode=link  gcc -pthread  -mlp64 -DHAVE_CONFIG_H -DHPUX11 -D_REENTRANT 
-D_HPUX_SOURCE   -I/home/te/httpd-2.2.8/srclib/apr-util/include 
-I/home/te/httpd-2.2.8/srclib/apr-util/xml/expat/lib  -version-info 2:12:2    
-o -rpath /apps/apache2.2/lib buckets/apr_brigade.lo 
buckets/apr_buckets.lo buckets/apr_buckets_alloc.lo buckets/apr_buckets_eos.lo 
buckets/apr_buckets_file.lo buckets/apr_buckets_flush.lo 
buckets/apr_buckets_heap.lo buckets/apr_buckets_mmap.lo 
buckets/apr_buckets_pipe.lo buckets/apr_buckets_pool.lo 
buckets/apr_buckets_refcount.lo buckets/apr_buckets_simple.lo 
buckets/apr_buckets_socket.lo crypto/apr_md4.lo crypto/apr_md5.lo 
crypto/apr_sha1.lo crypto/getuuid.lo crypto/uuid.lo dbm/apr_dbm.lo 
dbm/apr_dbm_berkeleydb.lo dbm/apr_dbm_gdbm.lo dbm/apr_dbm_ndbm.lo 
dbm/apr_dbm_sdbm.lo dbm/sdbm/sdbm.lo dbm/sdbm/sdbm_hash.lo 
dbm/sdbm/sdbm_lock.lo dbm/sdbm/sdbm_pair.lo encoding/apr_base64.lo 
hooks/apr_hooks.lo ldap/apr_ldap_init.lo ldap/apr_ldap_option.lo 
ldap/apr_ldap_url.lo misc/apr_date.lo misc/apr_queue.lo misc/apr_reslist.lo 
misc/apr_rmm.lo misc/apu_version.lo uri/apr_uri.lo xml/apr_xml.lo 
strmatch/apr_strmatch.lo xlate/xlate.lo dbd/apr_dbd.lo dbd/apr_dbd_mysql.lo 
dbd/apr_dbd_pgsql.lo dbd/apr_dbd_sqlite2.lo dbd/apr_dbd_sqlite3.lo   -lrt -lm  
-lpthread  /home/te/httpd-2.2.8/srclib/apr-util/xml/expat/lib/ 
/home/te/httpd-2.2.8/srclib/apr/ -lrt -lm -lpthread
gcc: +b: No such file or directory
 No such file or directory

I ran into "libtool" code and I think libtool script mistakenly passing
gcc the options: "+b ${libdir}" instead of "-Wl,+b -Wl,${libdir}".

Any ideas about if I'm missing something in my configuration? Or
how to fix this issue?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]