[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem upgrading Xorg--libtool issue?

From: David Ronis
Subject: Re: Problem upgrading Xorg--libtool issue?
Date: Sun, 12 Apr 2009 12:13:26 -0400

Hi Ralf,

Thanks for the reply.  I tried the dummy lib option and amazingly it
worked.  As far as I can tell, all the apps I've tried (whether part of
xorg or not) seeem to work.


On Fri, 2009-04-10 at 17:50 +0200, Ralf Wildenhues wrote:
> Hello David,
> sorry for the delay.
> * David Ronis wrote on Thu, Apr 02, 2009 at 10:06:51PM CEST:
> > I'm trying to build Xorg (the git master version) on a slackware 12.1,
> > i686 box using gcc 4.3.3 and libtool 2.2.6.  The build/install went
> > fine, but the result was a disaster--basically, none of my pre-existing
> > graphical programs (e.g., gnome, firefox) would work.  
> > 
> > The problem is that the pre-existing codes were linked against an older
> > version of Xorg, one that included something called
> > This lib is no longer in Xorg, the needed functionality having been
> > moved to other libraries.  Nonetheless, when I try to run something I
> > get errors relating to libxcb-xlib not being found.  Putting back the
> > old libxcb-xlib fails as some symbols are no longer defined.
> > 
> > The xcb folks have only one solution: rebuild everything.  I'm sure that
> > this will ultimately work, but given the effort required, is not
> > something I'm willing to do.
> It would be the only really clean solution though.
> > So, I was hoping someone can suggest an alternate solution.  For
> > example, can I simply remove the libxcb-xlib references from all the .la
> > files?  How about simply making a dummy library?
> Well, you can try this, but whether it has a chance to work at all
> depends on quite a few factors: whether the API or ABI have changed
> at all in the meantime, whether all libraries/programs that have a
> DT_NEEDED entry for also have DT_NEEDED entries
> for the libraries where the required symbols are in now, *and*
> their sonames have not changed, or at least something further up
> in the dependency tree loads the required code; whether symbol
> versioning has been used and if yes, whether the requires symbol
> versions all still exist; then it could also depend upon whether
> the Xorg people have not played games with -Bsymbolic.
> If I were to try it, then yes, making a symlink to a
> versioned dummy library (don't forget -Wl,-soname!)
> sounds like a good approach to me.
> Hope that helps.
> Cheers,
> Ralf

reply via email to

[Prev in Thread] Current Thread [Next in Thread]