[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

libtool-2 problem: Building a QT3 Designer plugin

From: Tim
Subject: libtool-2 problem: Building a QT3 Designer plugin
Date: Thu, 5 Nov 2009 18:50:23 -0500
User-agent: KMail/1.9.6

Hello, hope I'm asking the right list...

In muse (the audio/midi recording app),
 we have an .am file which is to build a
 single standalone 
 file, which can makes muse widgets 
 available to QT3 Designer.

With libtool-1, no problem, the single .so file
 is built and works with QT3 Designer.

libtool-2, however, insists on linking the runtime
 library (-lrt) with the .so, hence we get an
 error that main() is not found in the .so
I have tried to rework the .am file to make
 a LT library instead. 
What I end up with is an .so, an .la, and .a,
 and QT3 doesn't recognize them even if
 I dump them all into QT3's plugin/designer

When I compare the original libtool-1 generated 
 .so with the one I tried to make with libtool-2 and
 my re-worked .am file, they are quite different sizes 
 and contents.

Can anyone help me out here? 

I have attached the original .am file, and my
 attempted rework .am file.

You will see two 'sections'. One builds a
 convenience library libwidgets.a (no trouble there).
The other section builds the .so plugin library.
In my attempted rework, I have renamed the plugin 
 from musewidgetsplugin to  libmusewidgetsplugin,
 to satisfy naming conventions.

Thanks kindly.

Description: Text Data

Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]