[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

HELP: libtool 2.4.2 not compiling on Solaris 10u10 Sparc

From: Jeff Martin
Subject: HELP: libtool 2.4.2 not compiling on Solaris 10u10 Sparc
Date: Sun, 19 Aug 2012 10:11:26 -0700 (PDT)

I am trying to 
compile libtool so I can install another package which requires it. I 
have successfully compiled M4, Automake, Autoconf and installed in 
When I try to do the same for libtool, I receive errors.
I have tried the following:

./configure --prefix=/usr/gnu
Receive error:
libtool: Version mismatch error.  This is libtool 2.4.2, revision 1.3337,
libtool: but the definition of this LT_INIT comes from revision 1.3201.
libtool: You should recreate aclocal.m4 with macros from revision 1.3337
libtool: of libtool 2.4.2 and run autoconf again.
 Error code 63
make: Fatal error: Command failed for target 
Current working directory 
*** Error code 1
The following command caused the error:
fail= failcom='exit 1'; \
for f in x $MAKEFLAGS; do \
  case $f in \
    *=* | --[!k]*);; \
    *k*) failcom='fail=yes';; \
  esac; \
done; \

So I then tried from that same build directory, 

# /usr/gnu/bin/autoreconf --force --install
and that errors out with:
Can't exec "libtoolize": No such file or directory at 
/usr/gnu/share/autoconf/Autom4te/ line 345, <GEN3> 
line 6.
autoreconf: failed
 to run libtoolize: No such file or directory
autoreconf: libtoolize is needed because this package uses Libtool

Here are my settings:
Generic_147440-15 sun4v sparc SUNW,SPARC-Enterprise-T5120

echo $PATH


Summary of my perl5 (revision 5 version 8 subversion 4) configuration:
    osname=solaris, osvers=2.10, archname=sun4-solaris-64int
    uname='sunos localhost 5.10 sun4u sparc SUNW,Ultra-2'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=undef use5005threads=undef useithreads=undef 
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=define use64bitall=undef uselongdouble=undef
    usemymalloc=n, bincompat5005=undef

Any advice is appreciated, TIA.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]