[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: libtool problem with --whole-archive/--no-whole-archive

From: Venkatesh Vivekanandan
Subject: Re: libtool problem with --whole-archive/--no-whole-archive
Date: Tue, 17 Feb 2015 12:11:22 +0530

On 16 February 2015 at 14:38, Mike Frysinger <address@hidden> wrote:
On 26 Nov 2014 11:20, Venkatesh Vivekanandan wrote:
> Problem is, platform linker command doesn't have
> --whole-archive/--no-whole-archive around the lib. Instead it comes later
> in the command line.

iirc, libtool likes to sort things for you

> How to propogate the --whole-archive/--no-whole-archive all the way down to
> example app linking?. Importantly, it should be around the -lmyextlib. I
> can make changes only at platform/targetA/ as example/* is
> common across all other platforms.
> Note: Tried libtool's suggestion of -Wl,'-whole-archive -lfoo
> -no-whole-archive' as mentioned in
> but that didn't
> work.

what do you mean by "didn't work" ?
I meant linker command line didn't come out as I expected.

-Wl,--whole-archive -lmyextlib -ldl  -Wl,--no-whole-archive

 -lmyextlib -ldl

As explained, atleast platform linking has --whole-archive and --no-whole-archive, but examples didn't even had them

platform libtool link:
-lrt -lcrypto -lmyextlib -ldl  -pthread -O2 -pthread -Wl,--whole-archive -Wl,--no-whole-archive

example libtool link:
-lrt -lcrypto -lmyextlib -ldl  -pthread -O2 -pthread


maybe quoting is messing you up ?  you could try:

I tried this and didn't get the expected result.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]