lilypond-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: modifying default behaviour of tremolo slashes (issue 4636081)


From: janek . lilypond
Subject: Re: modifying default behaviour of tremolo slashes (issue 4636081)
Date: Sat, 27 Aug 2011 09:37:06 +0000

New patch set uploaded.


http://codereview.appspot.com/4636081/diff/42001/lily/stem-tremolo.cc
File lily/stem-tremolo.cc (right):

http://codereview.appspot.com/4636081/diff/42001/lily/stem-tremolo.cc#newcode61
lily/stem-tremolo.cc:61: return scm_from_double ((Stem::duration_log
(stem) >= 3 && get_grob_direction (stem) == DOWN && !(beam))
On 2011/08/23 07:48:39, MikeSol wrote:
!beam

Done.

http://codereview.appspot.com/4636081/diff/42001/lily/stem-tremolo.cc#newcode93
lily/stem-tremolo.cc:93: return ly_symbol2scm (((stemdir == UP && flag)
|| beam) ? "rectangle" : "beam-like");
On 2011/08/23 07:48:39, MikeSol wrote:
return ly_symbol2scm (style != ly_symbol2scm ("constant") && ((stemdir
== UP &&
flag) || beam) ? "rectangle" : "beam-like");

with proper indenting...

Done.

http://codereview.appspot.com/4636081/diff/42001/scm/define-grobs.scm
File scm/define-grobs.scm (right):

http://codereview.appspot.com/4636081/diff/42001/scm/define-grobs.scm#newcode1944
scm/define-grobs.scm:1944: (X-extent . ,ly:stem-tremolo::width)
On 2011/08/23 07:48:39, MikeSol wrote:
For consistency's sake (I just went through this with flags), keep
this as a
style property and document the possible values in the Stem_tremolo
docstring in
stem-tremolo.cc (the part with ADD_INTERFACE).

I'm not sure if i understand.  Do you say that i should rename shape to
style?

http://codereview.appspot.com/4636081/



reply via email to

[Prev in Thread] Current Thread [Next in Thread]