lilypond-user
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: partcombine & killCues


From: Aaron Hill
Subject: Re: partcombine & killCues
Date: Thu, 23 Jan 2020 20:16:58 -0800
User-agent: Roundcube Webmail/1.3.8

On 2020-01-23 8:00 pm, Aaron Hill wrote:
%%%%
\tag #'cueName <>_\markup \tiny \italic "Bsn."
\cueDuring #"bassoon" #DOWN { R1}
%%%%

If you need to use instrumentCueName or would simply prefer not to use text scripts, then you can do this:

%%%%
\cueDuring #"bassoon" #DOWN {
  \tag #'cueName \set CueVoice.instrumentCueName = "Bsn."
  R1
}
%%%%

If you do this enough, putting it in a music function will make your score much more readable:

%%%%
cueName = #(define-music-function (parser location name) (markup?)
  #{ \tag #'cueName \set CueVoice.instrumentCueName = #name #})

% . . .

\cueDuring #"bassoon" #DOWN { \cueName "Bsn." R1 }
%%%%


-- Aaron Hill



reply via email to

[Prev in Thread] Current Thread [Next in Thread]