[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Paparazzi-devel] problem: telemetry not displaying in GCS or messages

From: John Burt
Subject: [Paparazzi-devel] problem: telemetry not displaying in GCS or messages
Date: Thu, 22 Jan 2009 11:28:05 -0800

Hi all,

I've been trying for several weeks to solve a problem that has me dead
in the water and I hope someone can help.

I installed paparazzi a few months ago using the various wiki docs as my
guide (Ubuntu 8.10, paparazzi-dev,arm7, latest CVS tree, built using
make, etc). When I first installed, I was able to run the simulator for
various airframes and flight plans. However, something broke at some
point while I was configuring the software for my Tiny 2.11 and

Now, when I run paparazzi, I get a blank GCS display (i.e., no
instruments, buttons, messages, etc) in both simulation and ap sessions,
no matter what airframe file I try. When I click launch in the
simulator, the simulator seems to start, but still nothing shows in GCS.

I have tried removing paparazzi-dev and paparazzi-arm7, deleting the
paparazzi3 directory, and re-installing everything from scratch. GCS
remains stubbornly blank.

Here's what DOES work: I can compile the example airframes and my own
custom one. I can flash the Tiny 2.11 with an airframe, and can flash
the GPS tunnel code. With a terminal program I can watch messages from
Tiny arrive on the serial port. I can start ".../link -fg" and watch
tiny messages print out to console. Last night, Paul Cox and I flashed
my Tiny using his laptop and GCS and everything worked fine: his GCS
showed all the bells and whistles and reported IR sensors, etc. Still,
nothing on my laptop.

So, I suspect that there is a problem w/ my ivy bus or messaging system,
but I still don't understand why it doesn't work after I do an
uninstall / delete everything / re-install cycle.

Are there any debug commands I can use to track down the problem?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]