[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] Need help with connecting airplane to Paparazzi!

From: Brian Chang
Subject: Re: [Paparazzi-devel] Need help with connecting airplane to Paparazzi!
Date: Sun, 23 May 2010 20:26:39 -0700

Thanks a lot, with all your help we were able to get it working! We're able to obtain the data we need on the airplane now.

One more quick question: Is there any way to tell the airplane's orientation? (Like, which way it faces). Is that possible?

On Sun, May 23, 2010 at 3:33 PM, Pat Hickey <address@hidden> wrote:
I got sick of troubleshooting ttyUSB0/1 naming errors, so I made a udev rule that symlinks one name per adapter based on their unique serial numbers. Here's a sample from my /etc/udev/rules.d/10-ftdiadapters.rules

BUS=="usb", SYSFS{idProduct}=="6001", SYSFS{idVendor}=="0403", SYSFS{serial}=="A9007SF9", GROUP:="plugdev", MODE:="0660", SYMLINK:="ftdi0"

You can use udevadm to find out a device's serial number.


On Sun, May 23, 2010 at 7:51 AM, Felix Ruess <address@hidden> wrote:
Hi guys,

so you managed to flash the autopilot! Great, that is the first step...
It sounds like you tried to get a datalink connection to the autopilot through the USB cable. In the standard configuration that won't work.
This direct USB connection is for flashing the autopilot.
For the telemetry data you want to use your XBee modems (or a FTDI serial->USB cable). That means that on the autopilot side it uses the UART and not USB (by default). Your XBee USB Adapter (or your serial->USB cable) will normally show up as device /dev/ttyUSB0 (or ttyUSB1 if you already have one connected) which acts just like a normal serial port. Adjust the device parameter "-d /dev/ttyUSB0" accordingly if needed.
You can check with "dmesg | tail" after you plugged it in to which device it was bound.
You also might want to specify the baud rate that you set on your XBee as a parameter for the link. Just append e.g. "-s 57600" for a speed of 57600 baud.
Then probably save the session so you don't have to add this every time.

Cheers, Felix

On Sun, May 23, 2010 at 9:21 AM, Brian Chang <address@hidden> wrote:
Hi everyone, we're a student group from UCSD working with Paparazzi, in order to have a Multiplex Mentor model plane to take temperature data around our campus for sensor footprints. We're basically complete novices when it comes to this; we've had to self-learn it and the instruction manual we received for Paparazzi didn't help us solve our problems.

Our goal right now isn't to fly the plane, but just to have the plane connected to the computer so we can read the data given by Paparazzi (relating to the Attitude (pitch/roll/yaw, etc.)). We're just "walking" the plane around campus; with Paparazzi we want to be able to compensate for temperature differences when the plane is tilted at different orientations.

This image has been resized. Click this bar to view the full image. The original image is sized 1024x640.

Basically, right now we were able to establish a Plane-to-Computer connection (it does say "USB Device Found" in Paparazzi Center). However, when we execute a session the error that's shown in the screenshot occurs. And basically, we're stuck after that, and we've been stuck for a few weeks. Does anyone know what we're missing, or what the vital links are?

We have tried messing with the Airframe and Flight Plan files and trying to get the serial device to be ttys0 instead, but that didn't work. =(
Thanks for reading, and we appreciate any help we can get!

Paparazzi-devel mailing list

Paparazzi-devel mailing list

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]