[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AW: [Paparazzi-devel] Modem communication problems

From: Roman Nikitin
Subject: AW: [Paparazzi-devel] Modem communication problems
Date: Tue, 6 Jul 2010 20:24:12 +0100

It works fine, it looks like the modems communicate.(the funny thing warring
me is only that the "data in" led is not blinking on my modem) The problem
should be somewhere in GCS, maybe in airframe file. I am using microjet5.xml
to test the system. I proved the bauds for downlink it is 9600 and for GPS
it is 38400 (I have not configured GPS till now). The GPS and IRSs are
connected to the autopilot. Some Ideas what can be wrong with it?

After I execute Data link, server and GCS are running (no errors). The
problem I have I cannot see anything in GCS window, no map picture, no
control buttons. I cannot believe nobody had such problem. 

I am still looking for help.

Thank you.


-----Ursprüngliche Nachricht-----
Von: address@hidden
[mailto:address@hidden Im Auftrag
von Gareth Roberts
Gesendet: Dienstag, 6. Juli 2010 17:56
An: address@hidden
Betreff: Re: [Paparazzi-devel] Modem communication problems

Roman, do you have access to two computers?
Try using something like picocom  or screen(on linux) or Hyperterminal (on
windows) to chat between the two.  For example, under linux:
Laptop 1:
        screen /dev/ttyUSB0 9600
Laptop 2:
        screen /dev/ttyUSB0 9600
Laptop 1:
        Type "Hello World"
        Nothing should appear on the screen of laptop 1
Laptop 2:
        The words "Hello World" should magically appear.
You can also do this using one laptop.  Open two terminal windows and change
one of the device names to /dev/ttyUSB1.
If that doesn't work, it ain't a paparazzi problem!
Good luck, and I think you might be overcomplicating things - XBees usually
just magically work out of the box @ 9600.

On 6 Jul 2010, at 17:50, Roman Nikitin wrote:

> Hello guys, 
> I have still the same problem as before. I cannot get my modems speaking
to each other. I thought that it was the problem in my ap board, but now I
have a new one and the modems still does not work.
> My components are: TWOG, LEA-5H GPS, two IRSs, XBEE pro 802.15.4 modems. 
> The board is flashed with MJ5. One green and one red on the ap board are
> Modem configuration: First, I did default setting for both of the modems.
The baud is 9600 on both, the modem connected over USB is "coordinator" and
the modem connected to the ap board is "end device". Please, if somebody has
the same modem model as I have, let me know if the settings are right?
> I tried also to change the modem settings to "coordinator" and to "end
device" for both modem at the same time. It did not work. 
> So as I have the same problem with a new TWOG as with old one, I can see
that the problem is somewhere in Software or wires. The wires were
controlled twice by me. I am pretty sure they are right. So it should be
> Any ideas what I can do? I know it is difficult to explain everything via
e-mails and it takes a lot of time. It would be nice if you could find some
time to contact me over Skype or IRC channel. I am there tonight and during
the whole day tomorrow. 
> Thank you very much.
> Regards, 
> Roman
> Bristol Institute of Technology 
> University of the West of England
> Aerospace Systems Engineering
> email: address@hidden
> Mob.: +44 (0) 7760806643
> Skype: nikitin.roman   (in UK)
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden

Paparazzi-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]