[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

AW: AW: [Paparazzi-devel] GCS problem

From: Roman Nikitin
Subject: AW: AW: [Paparazzi-devel] GCS problem
Date: Thu, 8 Jul 2010 18:19:24 +0100



it is not the problem, the connection exist. However, to start the GCS I need push the button “Execute” several times. After that everything working fine, as I can see.


Thank you for the temperature sensitivity note.






Von: address@hidden [mailto:address@hidden Im Auftrag von David Carlson
Gesendet: Donnerstag, 8. Juli 2010 17:47
An: address@hidden
Betreff: Re: AW: [Paparazzi-devel] GCS problem



The best way to get a feel for what is happening with the data link device interface to your GCS computer is to run "sudo tail -f /var/log/messages"  This follows the kernel log.  Now when you plug in the USB cable for the GCS device, you will see it connect and attach to /dev/ttyUSBx (where x is 0-9).  I would suspect you are getting a faulty connection between your GCS and the modem, but this would tell you for sure.

And to answer your previous question, there are not really any components that are temperature sensitive (assuming you don't go below -60 C, above 80 C, etc)


On 07/08/2010 07:07 PM, Roman Nikitin wrote:



I tried really everything. What I could find is that I need to push the button Execute several times until the GCS is started properly. I get also sometimes a couple of the messages from OS (Ubuntu) about some kernel problems. I think that is why I have such problems. I have two OS on the laptop, Linux and WIN7.


Now, I know where the problem is. I will try to reinstall my OS, and will use jut one OS on one hard drive. I found in some forums that Linux and WIN don´t like each other. That is why sometimes some kernel errors appear.







Von: address@hidden [mailto:paparazzi-devel-bounces+roman.address@hidden] Im Auftrag von Maik Höpfel
Gesendet: Donnerstag, 8. Juli 2010 16:17
An: address@hidden
Betreff: Re: [Paparazzi-devel] GCS problem


Hey Roman,
There's definitely something at fault there. Both of our Paparazzi boards and components have proven very reliable. Check your power source and all connections. Pipe a short textfile over the Xbees to check for transmission errors. It should come out the same on both ends, you might use md5sum to check automatically. The Xbees do error checking, so there shouldn't be any difference, really.
Other than that, debug, try, eliminate possible sources of error one by one...

Good luck!
- maik

Am 08.07.2010 16:51 schrieb "Roman Nikitin" <address@hidden>:

After I tried to start the GCS 6-7 times it is working now. But I don´t  see why it happens. And I am still looking for the ideas.




Bristol Institute of Technology

University of the West of England

Aerospace Systems Engineering

email: address@hidden

Mob.: +44 (0) 7760806643


Paparazzi-devel mailing list

Paparazzi-devel mailing list


reply via email to

[Prev in Thread] Current Thread [Next in Thread]