[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Paparazzi-devel] can't get telemetry data from my TWOG

From: Maik Höpfel
Subject: Re: [Paparazzi-devel] can't get telemetry data from my TWOG
Date: Mon, 19 Jul 2010 16:25:26 +0200

Well, what happens if you hook up the TWOG directly via FTDI? It
should definitely work then, given that your airframe config file has
the correct baud settings.

If you hook up both modems to your PC, try to get a communication
between them working. It should work just out of the box, just reset
them in XCTU. Make sure you have the correct function sets flashed if
you use Xbees: one should be ZNET 2.5 COORDINATOR AT, the others

Also, let us know what the LEDs on your Xbees say. Are they receiving
something, are they sending properly?

You're correct in that no error message in the Paparazzi center means success.


2010/7/19 BX Guan <address@hidden>:
> I've spent hours trying to search the mentioned locations but I don't know
> exactly what to search for. and I've tried the suggested solutions.
> - there was no error on Paparazzi Center when launched
> - I hooked up the FTDI first as directed in the wiki. In fact I have 2 FTDI
> cable and have tried both of them
> - Then I tried to use modems, set them up with the X-CTU, still didn't work
> If there are no error messages from Paparazzi Center when I launch the GCS
> and stuff, that means that connection was established doesn't it? Anyway
> thanks for the response, I posted the question here hoping that someone
> would remember something that I didn't =P I'll just keep searching.
> On Mon, Jul 19, 2010 at 10:13 PM, Maik Höpfel <address@hidden> wrote:
>> Hey Bao,
>> the behavior that you describe happens when there's no telemetry link
>> and is not related to your GPS.
>> That's a common problem, and there are lots of info scattered around
>> the wiki, RCgroups Paparazzi thread and the mailing list. From the top
>> of my head:
>> - check the Paparazzi center for error messages when launching
>> - check XBee setup, baud rate, channels, Network ID, ...
>> - use a serial terminal to debug the modems: listen in to see if the
>> TWOG sends anything, try sending a message from one to the other...
>> - hook up a FTDI cable to the TWOG instead of a modem, see if it
>> outputs anything that way
>> - etc.
>> Regards,
>> Maik
>> 2010/7/18 BX Guan <address@hidden>:
>> > Hey guys, I've been trying to follow the steps to set up my TWOG to no
>> > avail.
>> >
>> > When I execute "Flight USB address@hidden" (ie follow until step 5 under
>> > "compiling" of wiki), the GCS will come up but the "screen" will be
>> > blank
>> > and the places where the buttons/messages etc usually are (below the
>> > screen)
>> > is just plain grey. I've tried both connecting the TWOG to my laptop via
>> > cable as well as attempting to do so via a modem but were unsuccessful.
>> > I have a slight suspicion that it's due to my GPS not being able to get
>> > a
>> > fix, and have tried configuring it with u-centre following instructions
>> > under "GPS" of wiki, manual configuration. Everything is pretty much as
>> > expected except that when I double click on POSLLH, SOL, STATUS, SVINFO,
>> > VELNED. They did not change from grey to black. Any thoughts?
>> >
>> > Thanks,
>> > Bao
>> >
>> > _______________________________________________
>> > Paparazzi-devel mailing list
>> > address@hidden
>> >
>> >
>> >
>> _______________________________________________
>> Paparazzi-devel mailing list
>> address@hidden
> _______________________________________________
> Paparazzi-devel mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]